Known Issue with Version 8.1 and Google Chrome – Now Resolved!

Known Issue with Version 8.1 and Google Chrome – Now Resolved!

Known Issue with Version 8.1 and Google Chrome – Now Resolved!

Original Post

We are currently investigating an issue with Google Chrome that is affecting a very small amount of people (roughly 20 total individuals at the time of this writing) attempting to log in using HTTPS to Version 8.1. This is believed to be caused after a security patch was applied early on 11/13 to keep communications as secure as possible. If you are experiencing issues connecting to your Version 8.1 account and are getting a “ERR_CONNECTION_ABORTED” error in Google Chrome, please switch to using Internet Explorer, Mozilla Firefox, or Safari while we work to find a solution. If you have any further questions or feedback please email us at support@workschedule.net.

We appreciate your patience and understanding as we work to find a solution in this matter!

Resolution

The issue with Chrome has been resolved as of 12:00 pm Eastern on Monday, November 17. Microsoft released a security update that we applied to our version 8 servers early on Thursday, November 13. Microsoft has since acknowledged that this was a faulty update. It prevented some Chrome users from connecting to any site secured with the TLS 1.2 protocol, including our version 8 servers. No other browsers appear to have been affected. We have since resolved this issue and all Chrome users should be able to access our site again. More (technical) information can be found by clicking this link.

We sincerely apologize for any inconvenience this may have caused and our engineers will continue to stay on top of any such issues that may arise in the future with an immediate response.